JugonesTop

¿Por qué no mi entrada/salida de señales funcionando correctamente? openttd

Me gusta usar bucles en mi tren de sistemas para agilizar la carga y descarga, con múltiples plataformas en cada estación. Cada circuito se alimenta en las estaciones y al final de cada tren que se alimenta de nuevo en el bucle. Yo uso la entrada/salida de señales en la entrada y bloquear las señales en la entrada de cada estación. El problema que me estoy quedando en esta estación en particular es que los trenes no son, después de la entrada/salida de señales de la manera correcta. Echa un vistazo a esta captura de pantalla:

enter image description here

El tren en el extremo derecho de la imagen no debería haber ido a el sendero de la mano izquierda, que tiene un rojo de señal de salida. Se debería haber ido hacia el sendero de la mano derecha que tiene un verde señal de salida. Ahora es innecesariamente esperando el tren para finalizar la carga en la plataforma pesar de que hay un vacío disponible. ¿Qué estoy haciendo mal?

Respuestas

Si usted está usando YAPF como pathfinder, que es el valor predeterminado en la actualidad, entonces creo que se puede solucionar este problema haciendo su ruta de señales de dos vías y la habilitación de yapf.rail_firstred_twoway_eol. Esto último se puede hacer de forma permanente mediante la apertura de su openttd .cfg (ver google donde encontrar ese archivo) y cambiar la línea:

yapf.rail_firstred_twoway_eol = false

a:

yapf.rail_firstred_twoway_eol = true

También puede habilitar este parámetro de forma temporal, mediante el juego de la consola (abrirlo con su tecla de tilde [`]) y entrar en:

set yapf.rail_firstred_twoway_eol 1

Para obtener más información sobre esta configuración, consulte:

En este caso he usado @yx y el asesoramiento que emplea un camino unidireccional de señales. Todavía no sé por qué la salida/entrada de señales no estaban funcionando como se pretendía.